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WARRANTY: 
 
BiPOM Electronics warrants MicroTRAK for a period of 1 year. If the product becomes defective during 
this period, BiPOM Electronics will at its option, replace or repair the product. This warranty is voided if 
the product is subjected to physical abuse or operated outside stated electrical limits. BiPOM Electronics 
will not be responsible for damage to any external devices connected to the microcontroller system. 
BiPOM Electronics disclaims all warranties express or implied warranties of merchantability and fitness 
for a particular purpose. In no event shall BiPOM Electronics be liable for any indirect, special, incidental 
or consequential damages in connection with or arising from the use of this product. BiPOM’s liability is 
limited to the purchase price of this product. 
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INTRODUCTION 
 
The PIC® micro-controller, introduced by Microchip in the early 90’s, is one of the most popular micro-
controllers in use today with applications ranging from industrial, medical, home automation to 
automotive.  
 
The objective of the MicroTRAK is to give students, engineers, technicians, hobbyists and other users 
experience with micro-controllers by developing practical applications using C and Assembly language. 
The MicroTRAK Lab Book consists of several labs that vary from simple to complicated.  
When used in a school environment, it is recommended that the labs accompany a micro-controller 
course during the semester. Depending on the duration of each lab during the week, each lab in the 
student manual can be covered during one or two lab weeks. Based on the remaining time during the 
semester, the instructor may have the students work on one or more advanced projects. Some advanced 
project ideas are listed in Advanced Project Ideas section of this manual. 
 
This User’s Guide is intended for the instructor to get familiar with and setup the MicroTRAK for the 
upcoming labs. The MicroTRAK Lab Book should be given to each student group in the lab to perform 
various exercises during the semester. 
 
MicroTRAK can also be used as a Project Kit for rapid prototype development and proof-of-concept. 
Keypad, LCD, microcontroller board and peripheral boards are already mounted on the carrier board, 
resulting in a presentable and single-piece assembly for demonstration purposes. LCD and keypad also 
facilitate software debugging.  
 
MicroTRAK consists of: 
 
• MINI-MAX/P18 Micro-controller Board 
• Training Board ( TB-1 ), PROTO-1 Prototyping Board 
• LCD with backlight ( adjustable brightness) , matrix keypad 
• Carrier board with extra regulator, I/O Module 
• MPLAB with Assembler, Debugger and Simulator (free download from Microchip web site) 
• Micro-IDE Integrated Development Environment with support for MPLAB from Microchip 
• Serial cable, Power Supply 
• Example Lab book and this User’s Guide 
 
The following external items are required for each Training Kit station: 
 
• Personal Computer (PC) with 

• Minimum 128MB memory and 1GB of available hard disk space  
• One available RS232 Serial Port 
• Windows 98/ME/NT/2000/XP/Vista/Windows 7 (32-bit or 64-bit) 

• (Optional ) Digital Voltmeter 
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INSTALLATION 
Installing the Hardware 
 
Place MicroTRAK on a clean, non-conductive bench top ( preferably on an anti-static mat ) 
 
Connect the provided power supply to the power plug on the MicroTRAK . Do not connect the power 
supply to the outlet yet.  
 
CAUTION: Do not use a power supply other than the one that is supplied with the MicroTRAK . Use of 
another power supply voids the warranty and may permanently DAMAGE the board or the computer to 
which the board is connected ! 
 
Make sure the PC is powered off. 
 
Connect one end of the RS232 serial cable to serial connector of MINI-MAX/P18 board as shown on 
Figure 1.  
 
Connect the other end of the serial cable to your PC’s COM port. 
 
Connect the 6VDC power supply to a suitable wall outlet. Power LED on MicroTRAK Carrier Board will 
turn ON. 
 
 
 

 
Figure 1 
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Installing the Software  
 
Software for the system consists of two packages: 
 
1. Micro-IDE from BiPOM Electronics: This is a free download. 
2. MPLAB from Microchip: This is also a free download. 
 
Micro-IDE 
 
Micro-IDE is an Integrated Development Environment for micro-controller systems application 
development. Micro-IDE integrates essential components of software development including: 
 
• Multi-File Editor  
• Project Manager 
• C Compiler, Assembler, Linker 
• Optional Micro-controller Simulator 
• Terminal program, Calculator, ASCII Chart 
• Serial Port Loader 

 
Since Microchip’s MPLAB has similar features, we will use MPLAB as our main development 
environment and use Micro-IDE only as a serial downloader and serial terminal. 
 
Micro-IDE is a part of BiPOM’s MC Development System: 
Download and run pic_devsys.exe from http://www.bipom.com/web_softwares/318931.html 
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Please read the agreement and click Yes to continue. 
 
Enter your name, company and ‘FREE’ as a serial number. Then click the Next button. 
 

 
 
 
Select the disk location where the software has to be installed. The default location (c:\bipom\devtools) is 
recommended. Click the Next button to start the installation. 
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. 

 
 
Click Next. Select the Program Folder where the icons for Micro-IDE will be installed.  Default selection 
is Micro-IDE folder: 
 
 

 
 
Click Next. Micro-IDE will be installed. 
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Uncheck the “I would like to launch Micro-IDE” option and click the Finish button.  
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MPLAB 
 
Download and install the latest MPLAB® IDE from Microchip® website. The location of MPLAB on 
Microchip web site may change from time to time. To find the latest MPLAB, please visit 
www.microchip.com first. Select Development Tools from Design tab: 
 

 
Download MPLAB IDE: 
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When you click on the link, zip file will start downloading: 
 

 
 
Extract the contents of the zip file to a temporary directory ( for example, c:\temp ) and run setup.exe 
from within the zip file: 
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MPLAB Installation will start: 
 

 
 

 
 
Click Next. Accept the license agreement: 
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Click Next. 
 

 
 
Select Complete. Click Next. 
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Click Next to install to default location. 
 

 
 
Accept the agreement and click Next. 
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Accept the agreement and click Next. 
 

 
 
Click Next. 
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Installation will start: 
 

 
 
The installation program may ask you to install HI-TECH C after the MPLAB installation is complete. It is 
OK to click Yes and install HI-TECH C although it is not needed for the purpose of this User Guide. 
 
At the end of installation, you may be asked to restart your computer. Make sure that all your open 
programs are closed and your data is saved and click Finish restart your computer: 
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After your computer restarts, you can start MPLAB from Start->Programs: 
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Opening Projects 
 
MC Development System is distributed with several example programs that illustrate how to program the 
PIC® micro-controller. 
 
To open the example projects, start MPLAB and select Project menu. Select Open. 
 

 
 
PIC18 example projects are located under the path: 
 
\bipom\devtools\MPASM\Examples\pic18 
 
Select the project io.mcp: 
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MPLAB will open the project and display the Project View: 
 

 
 
 
Double click on io.asm to open the source file: 
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The io.asm assembly language source file will appear: 
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You can scroll down to see the assembly instructions of io.asm: 
 

 
 
Select Project->Build All to build the project: 
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The project will build, io.asm file will be compiled and an io.hex output file will be generated. The results 
of the Build are displayed in the Build Window: 
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Downloading Programs 
 
To download projects, Micro-IDE is used. We have created project files for both Micro-IDE and MPLAB 
for all the PIC® examples. The code can be developed and simulated in MPLAB and downloaded to the 
actual hardware using Micro-IDE. Micro-IDE also has a terminal emulator window that allows monitoring 
the RS232 serial output from the MINI-MAX/P18 board. 
 
Start Micro-IDE by selecting Start, Programs and Micro-IDE. Select the Micro-IDE option under Micro-
IDE folder. This will start Micro-IDE. 
 

 
 
When Micro-IDE is started, the Project selection window appears: 
 

 
 
Click Cancel for this first time because you will first configure communications before opening a project. 
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After you have started Micro-IDE, configure the correct COM port and communications parameters: 
 
1. Select Tools and Options from the Micro-IDE menu. 
 
2. Under Terminal tab, make sure Com Port is selected as the port that you connected to the  
MINI-MAX/P18 board. For example, if the board is connected to COM1, select COM1 under Terminal 
tab. Make sure that the Terminal options are set as follows: 
 
Baud Rate: 19200 
Data Bits: 8 
Stop Bits: 1 
Parity: None 
Echo: Off 
 
3. Under Loader tab, make sure Com Port is selected as the port that you connected MINI-MAX/P18 
board. For example, if the board is connected to COM1, select COM1 under Loader tab. Make sure that 
the Loader options are set as follows: 
 
Baud Rate: 19200 
Data Bits: 8 
Stop Bits: 1 
Parity: None 
Echo: Off 
 
4. Open the Terminal window by selecting Terminal under View menu. A blank terminal screen will 
appear on the right side of the Micro-IDE window. You can resize the terminal screen by selecting the left 
edge of the terminal window with the left mouse button and dragging to the right. 
 
5. Check communications to the MicroTRAK. Start the Terminal program by selecting Terminal under 
View menu. A blank terminal screen will appear on the right side of the Micro-IDE window. You can 
resize the terminal screen by selecting the left edge of the terminal window with the left mouse button 
and dragging to the right. 
 
6. Select Tools, Terminal and Connect. This will open the COM port and connect the terminal to the 
MINI-MAX/P18. 
 
Make sure the MINI-MAX/P18 board is powered and connected to the PC as described in the section 
Installing Hardware.  
 
Open the io.prj project that is under: 
 
\bipom\devtools\MPASM\Examples\pic18 
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Download the file to the board by selecting Download under Build menu: 
 

 
 
 
 
 
 
If the board is powered and connected properly to the PC, a progress dialog will appear: 
 

 

Download 
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The progress dialog will disappear following a successful download. Details of the download are shown 
on the Output Window: 
 

 
 
 
 
When the download is finished, the progress indicator disappears. This means that the board has 
received the program successfully. 
 
 
After the program has been successful downloaded, it can be started using the Mode button on the main 
Toolbar: 
 

 
 
 
 
Mode button puts the board into Run or Program mode. In Run mode, the micro-controller is executing 
the program in its memory. In Program mode, the micro-controller is in Reset state so no programs are 
running. In Program mode, micro-controller’s flash memory can be changed and a new program can be 
downloaded. 
 
The Mode button is Red in Program mode and Green in Run mode. Following a download, the Mode 
button will be Red. Click the Mode button to change the mode to Run mode. The program io.hex that 
you just downloaded starts executing.  
 
The program io.hex will blink the LED’s that are connected to PORT D on MicroTRAK’s I/O Module. 
 
Congratulations!!!  You have built and executed your first program on MicroTRAK. 
 
Click the Mode button once again so it turns Red. The board is in Program mode now and it will stop 
running and the LED’s will not blink any more. 

Mode 
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Creating Projects 
 
To create your own project, start MPLAB. Select Project->New: 
 
 

 
 
 
Specify project name and location: 
 
 

 
 
 
Click OK. 
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Create a new file by selecting File->New: 
 

 
 
 
MPLAB will open a new window and show the empty file: 
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Select File->Save As: 
 

 
 
 
Save the file as test.asm to c:\test folder: 
 

 
 
Click Save. 
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Now add this new file test.asm to the test project. Select Project->Add Files to Project: 
 

 
 
Select test.asm from c:\test to add to the project: 
 

 
 
Click Open. 
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In the test.asm source file window, type the following to configure the program for PIC18F458 
microcontroller: 
 
 list      p=18f458 
 
 #include <p18F458.inc> 
 
 CONFIG OSC = HS , BOR = ON , BORV = 45 , WDT = OFF, STVR = ON 
 
Note: When typing, put a tab character before each line in the assembler. Otherwise you may get 
warnings from the assembler. 
 
list command specifies the microcontroller type as PIC18F458 
 
#include defines the include file to include in this project. In this case, we use the include file 
p18F458.inc that contains the PIC18F458 specific register names and definitions. 
 
CONFIG command specifies the special hardware configuration values for PIC18F458. In this case: 
 
OSC = HS ( this means, we selected high speed crystal as the clock source ) 
 
BOR = ON ( this means that Brownout detect feature is enabled ) 
 
BORV = 45 ( this means that the Brownout value is set at 4.5 Volts, supply voltages below 4.5 Volts will 
results in microcontroller reset ) 
 
WDT = OFF ( Watchdog timer is disabled ) 
 
STVR = ON ( A stack overflow will reset the PIC18F458 ) 
 
 
 
The resulting source file window will look like this: 
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Now type the following small assembly language program: 
 
 
movlw   b'00000000'    
movwf   TRISC 
   
movlw   b'11111111'   
movwf   PORTC 
 
b is the symbol for binary notation. For example, b'11111110' is the equivalent of 254 decimal or FE 
hex. 
 
TRISC is the data direction register for I/O PORT C. PORTC is the data register for I/O PORT C. 
 
This simple program sets first bit of PORT C ( also referred to as RC0 ) as an output and then clears this 
bit. 
 
Finally, add the keyword END at the end of your program to tell the assembler where the program ends. 
The resulting source file will look like this: 
 

 
 
Save the file by selecting File->Save. 
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The next step is to build the project. Select Project->Build All: 
 

 
 
 
On the first build, MPLAB will prompt with the following question: 
 

 
 
Select Absolute.  



34 

MPLAB will open the Build Window and build the project successfully if the source file was typed 
correctly: 
 

 
 
The successful build generates several files, including test.hex which is the output file that will be 
downloaded to the MINI-MAX/P18 board. 
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Simulation 
 
You can simulate the micro-controller and single-step through your program without actually having the 
MINI-MAX/P18 connected to your PC.  MPLAB has a built-in PIC® microcontroller simulator  
 
To start the simulation, first specify the simulator/debugger to use by selecting  
Debugger->Select Tool->MPLAB SIM. MPLAB SIM is the simulator that is built-in to MPLAB. 
 

 
 
 
We will start the simulation by resetting the 18F458 microcontroller ( in simulation mode ). Select  
Debugger->Reset->Processor Reset: 
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This will reset the simulated microcontroller and place the current program position indicator ( Program 
Counter ) on the first executable line of code: 
 
 

 
 
 
The green arrow shows the current instruction that is about to be executed. 
 
Selecting the Debugger menu, you will notice that there are keyboard shortcuts for Simulator operations: 
 
F7 for Step Into 
F8 for Step Over 
F9 for Run 
F2 for Breakpoints 
 
These keyboard shortcuts are faster and easier to use than menu operations and are recommended. 
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Press F7 and the green arrow will move to the next executable instruction: 
 

 
 
To view the simulated PIC18F458 registers, select View->Special Function Registers: 
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Special Function Registers window will appear: 
 

 
 
Click on SFR Name column to sort by SFR name. Scroll to TRISC. The value of TRISC is now FF hex. 
This is the default value upon reset. 
 
Press F7 to step one more instruction. This will cause the instruction 
 
movwf   TRISC 
 
to execute and this instruction will assign the value of W ( Accumulator ) to TRISC. Since W was 
assigned a value of b'11111110' ( FE hex ), TRISC will now have this value. The new value of TRISC is 
updated and shown in the Special Function Registers window: 
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Another convenient method of watching variables and special function registers is to use the Watch 
window. Select View->Watch: 
 

 
 
This will open Watch window. Select the Special Function Register to be watched from the left pull down 
list. In this case, we are using PORTC in our program so we can watch the value of PORTC: 
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41 

After selecting PORTC, click the Add SFR button. PORTC will be added to the list of variables to be 
watched and its current value will be displayed: 
 

 
 
 
Press F7 twice to single step over the lines: 
 
movlw   b'11111110'   
movwf   PORTC 
 
The value of PORTC will change from to FE hex: 
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Debugging 
 

There are few options for debugging your programs on the MicroTRAK/P18. You can use the LCD 
display, LED’s on I/O Module and/or printing to RS232 terminal as visual means to debug your program. 
Alternatively, you can use an In-Circuit Debugger (ICD) provided by Microchip. Table 1 shows various 
options for debugging: 

 

 

Debugging using LCD display, LED’s on I/O Module and/or printing to RS232 
terminal as visual means to debug 

 

PICKit™ 3 Debugger from Microchip 

 

ICD2 Debugger from Microchip 

 

ICD3 Debugger from Microchip 

 

Table 2
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Debugging with ICD2 
 
You can skip this section if you do not have a Microchip ICD2 Debugger. 
 
For effective debugging, MINI-MAX/P18 supports Microchip ICD2 Debugger; this must be purchased 
separately. While it is possible to debug simple programs by printing to terminal, LCD display or by 
activating LED’s, a hardware debugger such as the ICD2 is a very valuable tool that allows single-
stepping through your PIC18F programs as they execute on the actual microcontroller, setting hardware 
breakpoints and watching microcontroller registers and program variables. 
 
ICD2 Debugger connects to MINI-MAX/P18 through a simple adapter board from BiPOM called PIGGY. 
A photo of PIGGY is shown in Figure 2: 
 

 
 

Figure 2 
 
 
 
To setup MINI-MAX/P18 for debugging: 
 
• Disconnect  the power from MINI-MAX/P18 board 
• Remove the PIC16F648 from  its 18-pin DIP socket. You can use a small flat head screwdriver or a 

special IC extractor tool for this purpose. Be careful not to bend the pins of PIC16F648. 
• Observe correct direction and plug the PIGGY into the 18-pin DIP socket. 
• Check whether 2 jumpers are installed to X3 jumper block. See Figure 3: 
 

 
 

Figure 3 
 
• Connect ICD2 Debugger to USB interface and install USB drivers. 
• ICD2 comes with a 6-wire cable that has RJ11 ( phone jack ) style connectors on each end.Connect 

one end of the 6-wire cable to ICD2 Debugger. 
• Connect the other end of the 6-wire cable to ICD2 adapter which is installed to MINI-MAX/P18 board. 
 
IMPORTANT NOTE! DO NOT POWER THE TARGET BOARD (MINI-MAX/P18) UNTIL THIS POINT. 
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Figure 4 shows a photo of the complete setup: 
 

 
 

Figure 4 
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To start the debug session: 
 
• Run MPLAB and open  the icd2 test project ( Project->Open 

:\bipom\devtools\MPASM\Examples\ICD2) 
• Build the project ( Project->Build All) 
• Select Debug tool (Debugger->Select Tool->MPLAB ICD2) 
 

 
 
• Go to Debugger->Settings->Power and check if “Power target circuit from MPLAB ICD2” 

checkbox is unchecked. This is very important. Please make sure that this checkbox is always 
unchecked when you create a new project. 

 
• Connect RS-232 cable to the target MINI-MAX/P18 board and to COM port of your PC. 
• Power the target MINI-MAX/P18 board  
• Press “Update” button 
• Target Vdd should display correct  voltage ( about 5V) 
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• Run Micro-IDE and press “Connect” icon button. 
 

 
 
• Press “Program Target Device” to download the code to the target MINI-MAX/P18 board:  
 

 



47 

 
 
 
• Press “Step Into” to start Debug Session  
 

 
 
• Set breakpoint 
 

 
 
• Press “Run”  
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• Micro-IDE terminal shows the results of debug session  
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Important: LVP mode 
 
If the code is debugged using ICD2 debugger the LVP ( low-voltage programming) mode will be disabled 
automatically. If LVP is disabled it is impossible to download any code to the board using built-in 
PIC16F648 programmer because it uses LVP method. 
 
In order to solve that issue and enable LVP: 
• Run MPLAB and open the enLVP test project  

( Project->Open C:\bipom\devtools\MPASM\Examples\EnableLVP\enLVP.mcp ) 
• Build the project ( Project->Build All) 
• Select  Programmer tool (Programmer->Select Programmer->MPLAB ICD2) 
• Erase the part (Programmer->Erase Part) 
• Program the part ( Programmer->Program) 
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Debugging with PICKit™ 3 Debugger 
 
You can skip this section if you do not have a Microchip PICKit™ 3 Debugger. 
 
For effective debugging, MINI-MAX/P18 supports Microchip PICKit™ 3 Debugger; this must be 
purchased separately. While it is possible to debug simple programs by printing to terminal, LCD display 
or by activating LED’s, a hardware debugger such as the PICKit™ 3 is a very valuable tool that allows 
single-stepping through your PIC18F programs as they execute on the actual microcontroller, setting 
hardware breakpoints and watching microcontroller registers and program variables. 
 
PICKit™ 3 Debugger is shown in Figure 5: 
 

 
 

Figure 5 
 

PICKit™ 3 Debugger connects to MINI-MAX/P18 through a simple adapter board from BiPOM called 
PIGGY. A photo of PIGGY is shown in Figure 6: 
 

 
 

Figure 6 
 
 
PIGGY is normally designed for ICD2 Debugger but PICKit™ 3 Debugger can also be connected using a 
small adapter piece called “RJ11 to ICSP adapter” ( Part#: AC164110 from Microchip ). Figure 7 shows 
this adapter kit: 
 

 
Figure 7 
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To setup MINI-MAX/P18 for debugging: 
 
• Disconnect  the power from MINI-MAX/P18 board 
• Remove the PIC16F648 from  its 18-pin DIP socket. You can use a small flat head screwdriver or a 

special IC extractor tool for this purpose. Be careful not to bend the pins of PIC16F648. 
• Observe correct direction and plug the PIGGY into the 18-pin DIP socket. 
• Check whether 2 jumpers are installed to X3 jumper block. See Figure 8: 
 

 
 

Figure 8 
 
• Connect PICKit™ 3 Debugger to USB interface and install USB drivers. 
• PICKit™ 3 Debugger comes with a 6-pin female connector that connects to the 6-pin pin connector on 

RJ11 to ICSP Adapter. Connect PICKit™ 3 Debugger to RJ11 to ICSP Adapter. Connect RJ11 to 
ICSP Adapter to PIGGY using the cable that has RJ11 ( phone jack ) style connectors on each end ( 
this is provided with RJ11 to ICSP Adapter ).  

• Connect the other end of the 6-wire cable to PIGGY which is installed to MINI-MAX/P18 board. 
 
IMPORTANT NOTE! DO NOT POWER THE TARGET BOARD (MINI-MAX/P18) UNTIL THIS POINT. 
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Figure 9 shows a photo of the complete setup: 
 

 
 

Figure 9 
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To start the debug session: 
 
• Run MPLAB and open  the io project ( Project->Open \bipom\devtools\MPASM\Examples\pic18\io ) 
• Build the project ( Project->Build All) 
• Select Debug tool (Debugger->Select Tool->PICKit 3) 
 

 
 
• Go to Debugger->Settings->Power and check if “Power target circuit from PICKit 3” checkbox 

is unchecked. This is very important. Please make sure that this checkbox is always 
unchecked when you create a new project. 

 
• Connect RS-232 cable to the target MINI-MAX/P18 board and to COM port of your PC. 
• Power the target MINI-MAX/P18 board  
• Press “Refresh Voltage” button under Status tab 
• Target Vdd should display correct  voltage ( about 5V) 

 

 
 
Click OK. 
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• Run Micro-IDE and press “Connect” icon button. 
 

 
 
• Press “Program Target Device” to download the code to the target MINI-MAX/P18 board:  
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• Press “Step Into” to start Debug Session. By clicking Step Into button many times, you can single step 

through the program: 
 

 
 
 
• Press “Run”  
 

 
 
 
The yellow LED’s on I/O Module on MicroTRAK will blink as the program runs. 
 
Important: Due to a design shortcoming in PICKit™ 3, this tool can be used only for debugging but not 
for programming. PICKit™ 3 does not actively control PIC18F458 reset line to allow programming. 
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MicroTRAK/P18 Complete Carrier Board 
 
Overview 
 

MicroTRAK/P18 Complete includes MicroTRAK Carrier Board, MINI-MAX/P18 Microcontroller Board, 
TB-1 Training Board, PROTO-1 Prototyping Board, I/O Module for PIC®, LCD242 LCD, KP1-4X4 
Keypad, Cables, Adapter, Training Manuals, Labbook, Micro-IDE, example projects, MPLAB with 
Assembler, Debugger and Simulator (free download from Microchip®), Serial downloader. 

 
 
 
MicroTRAK carrier board has the following configuration: 
 
• Sockets for a microcontroller board 
• Sockets for dual peripheral boards 
• Keypad interface 
• Industry-standard display interface for alphanumeric LCD and VFD displays. 
• Connectors and cables for connection to a standard breadboard 
• Expansion port for a microcontroller-specific pluggable I/O module with port connectors, port 

indicator LED's and port control DIP Switches. 
• Configuration of the high speed input via 3 jumpers. 
• Single operating unregulated voltage from 6 to 12 Volts DC 
• On-board 5 Volt regulator 
• Dimensions are 8.8 X 6.7 inches (22.4 X 17.0 centimeters). 
• Mounting holes of 0.15 inches (3.8 millimeters) are on four corners. 
• 0° - 70° C operating, -40° - +85° C storage temperature range. 
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I/O Module 
 
Overview 
 

I/O Module is a highly useful part of MicroTRAK training kit system for use with MINI-MAX/P18 Single Board 
Computers (SBC). MicroTRAK is the ultimate training kit and project development platform with microcontrollers.  
 
I/O Module allows access to all input/output (I/O) ports of the PIC18F458 micro-controller on the MicroTRAK 
development platform. I/O Module has 32 switches to control the PIC18F458 microcontroller inputs and 32 LED’s to 
indicate the port statuses as logic LOW or logic HIGH. 
 
I/O Module is powered from a 5 Volt regulated DC power source through the 36-pin input/output connector. 
 

 
 
 
I/O Module has the following configuration: 
 
• 36-pin pluggable module connector 
• Two 32-pin expansion connector footprints ( for soldering of wires or connectors by the user ) 
• 32 DIP switches to control the PIC18F458 micro-controller inputs 
• 32 port indicator LED’s with 74ALS05 hex inverters as drivers 
• Requires regulated 5VDC supply at 250mA maximum current ( when all LED’s are on ) 
• Dimensions are 5.95 X 1.975 inches (15.1 X 5.0 centimeters). 
• Mounting holes of 0.15 inches (3.8 millimeters) are on four corners. 
• 0° - 70° C operating, -40° - +85° C storage temperature range. 
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MINI-MAX/P18 Micro-controller Board 
 
Overview 
 
MINI-MAX/P18 is a general purpose, low-cost, highly reliable, and highly expandable micro-controller 
system. It is based on the Microchip Technology PIC18F458 single-chip Flash micro-controller. This 
microcontroller features      
• 32K In-System Re-programmable Downloadable Flash Memory 
• 1.5K RAM 
• 256 bytes of EEPROM data memory 
• 15 Interrupt Sources 
• Two 8-bit Timers / counters with prescalers 
• One 16-bit timer / counter 
• Two 16-bit compare / capture PWM modules 
• 10-bit 8-channel ADC 
• Two analog comparators 
• Programmable UART Serial Channel 
• SPI and Master I2C Serial Interfaces 
• Controller Area Network (CAN) Bus 
• Programmable Watchdog Timer  
• Brown-out detector 
• 33 general purpose I/O pins 

 
MINI-MAX/P18 board complements these features by providing  

• 512-byte EEPROM (optional 128-Kilobyte EEPROM) 
• RS232 Serial Port 
• In-circuit Programming of the micro-controller through the serial port 
• Precision reference voltage source for ADC 
• Keypad connector 
• LCD connector (with programmable contrast adjustment for LCD) 
• Expansion bus interface to low-cost peripheral boards. 
 
MINI-MAX/P18 board also supports PIC16F877A, PIC18F442 and PIC18F452 micro. These devices are 
pin compatible with the PIC18F458 and can be directly placed into the MINI-MAX/P18 PLCC-44 socket. 
 
 MINI-MAX/P18 is a highly reliable system: 
 
• 2-layer Printed Circuit Board 
• Hardware Watchdog timer of PIC18F458 provides protection against software failures and lock-ups.  
• PIC16F648 In-System programmer supports Software Watch-Dog timer. Timeout is selectable from 1 

to 127 seconds. If this function is activated, the PIC18F458 should communicate with PIC16F648 
through I2C bus to prevent RESTART. When PIC18F458 fails to communicate with PIC16F648, the 
PIC16F648 will generate a RESET signal for PIC18F458. 

• PIC16F648 generates reliable RESET signal in power-up and in brownout. 
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Specifications 
 
Dimensions are 2.35 X 2.40 inches (5.97 X 6.10 centimeters). Mounting holes of 0.125 inches (3 
millimeters) on four corners. 0° - 70° C operating, -40° - +85° C storage temperature range. 
 
Functional Blocks 

 
Figure 1 shows block diagram of the MINI-MAX/P18 system 
 
                                                6-12V @100mA                                          +5V 
                                                
          
 
 
 
 
                                                       
 
 
 
 
 
 
 
                                                                                 Figure 1 
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Micro-controller 
MINI-MAX/P18 has a Microchip PIC18F458 micro-controller (U2). Micro-controller ports and power lines 
are provided on a 20-pin Expansion bus (J4) for interfacing to peripherals and other external circuits. 
PIC18F458 has five ports: 6-bit PORTA, 8-bit PORTB, 8-bit PORTC, 8-bit PORTD and 3-bit PORTE. All 
of these port pins can be used as general I/O. 
Four PORTB lines and three PORTE lines are available on the LCD connector. PORTE lines can be 
used as analog inputs. Some of PORTA, PORTB and POTRC lines are available on the Expansion 
connector for general I/O or have special alignments such as asynchronous serial port, interrupt inputs, 
A/D inputs, and timer inputs. PORTD is available on the keypad connector. 
MINI-MAX/P18 has Pulse Width Modulation (PWM) circuit, which can vary LCD contrast. Alternatively it 
can be used as a low speed analog output. 
More information on the PIC18F458 micro-controller can be obtained from Microchip’s web site at 
www.microchip.com.   
 
Using the Analog to Digital converter 
PIC18F458 has an 8-channel 10-bit analog to digital converter.  It can use on-board +5V power (Vcc) as 
reference voltage. For best accuracy and noise performance, ADC can be configured to use external 
reference that is provided on the MINI-MAX/P18 board. It is permanently connected to RA3. Also, for this 
purpose MINI-MAX/P18 board has separate ground circuit for analog signals. This circuit is RA2 (pin #7 
on expansion connector). JP3 jumper should be set to use RA2 as the analog ground. MINI-MAX/P18 
board comes with JP3 jumper, already installed at the factory. 
 
EEPROM 
MINI-MAX/P18 uses a 24C04 (U5) 512-byte Electrically Erasable Programmable Read-Only-Memory 
(EEPROM). Typically this EEPROM is used for storing calibration values for sensors, customer 
identification, serial number and other parameters. This EEPROM is on a socket and can easily be 
replaced with higher capacity EEPROM’s (up to 128 Kilobytes). 
 
In-System Programming 
PIC18F458 micro-controller can be re-programmed remotely over the RS-232 interface using a second 
micro-controller on the board ( PIC16F648 ). The in-circuit programming feature simplifies program 
development on the board since downloading programs from a host PC takes only few seconds.  
 
MC Development System based on Micro-IDE Integrated Development Environment from BiPOM 
Electronics fully supports in-system programming on the MINI-MAX/P18 board using the serial port. A 
Windows-based program WinLoad from BiPOM Electronics is provided to download programs to the 
MINI-MAX/P18 board.  
 
Also, BiPOM Electronics provides a special piggyback module called PIGGY. Using this module, the 
user can connect the Microchip MPLAB-ICD to MINI-MAX/P18. 
 
Microchip's In-Circuit Debugger, MPLAB-ICD, is a powerful, low-cost development and evaluation kit for 
the FLASH PIC16F87XA microcontroller (MCU) family. MPLAB ICD utilizes the In-Circuit Debugging 
capability of the PIC16F87XA. This feature, along with Microchip's In-Circuit Serial Programming™ 
(ICSP™) protocol, offers cost-effective in-circuit FLASH programming and debugging from the graphical 
user interface of the MPLAB Integrated Development Environment (IDE). A designer can develop and 
debug source code by watching variables, setting break points, and single-stepping. Contact Microchip 
Technology’s Web site at www.microchip.com for information on how to use the MPLAB ICD. 
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Keypad connector 
8 pins of PORTD are connected to the Keypad connector. Many different keypads (for example, 3 by 5 
or 4 by 4) can be connected directly to the keypad connector. 5 Volt and Ground power lines are also 
available on the Keypad connector. This connector can also be used as a general-purpose port.   
  

Keypad Connector (J1) 
Signal Pin 
RD0 1 
RD1 2 
RD2 3 
RD3 4 
RD4 5 
RD5 6 
RD6 7 
RD7 8 
Ground 9 
Vcc 10 

        
Table 1. 

 
LCD Connector 
This connector is intended for various types of alphanumeric LCD modules. RB0, RB1, RB2, RB4 are the 
4-bit data bus, RE0, RE1, RE2 are the control signals. All these lines can be used as general purpose 
I/O. RE0-RE2 can serve as analog inputs.  Vee is a slow analog PWM output to adjust contrast of LCD 
display. Alternatively, it can be used as a general-purpose analog output. 
 

LCD Connector (J3) 
Signal Pin Pin Signal 
Ground 1 2 Vcc 
Vee 3 4 RE2 
RE0 5 6 RE1 
N/C 7 8 N/C 
N/C 9 10 N/C 
RB0 11 12 RB1 
RB2 13 14 RB4 

 
Table 2 

 
Power Supply Unit 
MINI-MAX/P18 series boards come with a 6 Volt unregulated DC power supply. Other power supplies 
can also be used although this invalidates the warranty. External power supply should be able to supply 6 
to 12 Volts DC at minimum 100mA current. The inner pin of the power supply connector is positive and 
the outer ring is negative. 
WARNING: Correct polarity should be observed when applying external DC supply to Power terminal; 
otherwise MINI-MAX/P18 will be permanently damaged. 
MINI-MAX/P18 has an on-board 5 Volt regulator (U3).  
CAUTION: Depending on the current requirements of the any external circuitry such as peripheral 
boards that are attached to MINI-MAX/P18 and the level of input voltage applied, the power regulator U3 
may dissipate enough heat to cause skin injury upon touch. Contact with this regulator should be avoided 
at all times, even after the power to circuit has been switched off.  
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Asynchronous Serial Port 
One asynchronous RS232 serial port (J2) is available on MINI-MAX/P18. 
U1 converts micro-controller’s RXD and TXD pins to/from RS232 levels. U1 has built-in voltage-doubler 
and inverter that generates +/- 10 Volts for RS232 logic levels. RS232 port is made available on a 9-pin 
male D connector J2. Hand-held terminals, computers, modems and other serial devices may be 
connected to the RS232 port. CTS/RTS Modem control lines are provided on the RS232 port. CTS is 
used by external host such as a PC to put MINI-MAX/P18 in program or run modes. Therefore, user 
applications must not use CTS line. 
 

RS232 Serial Port (J2) 
 

 
 
 
 
 
 
 
 
 
 
 

Table 3 
 
Many users try to use HyperTerminal to send some data bytes to a MINI-MAX/P18 board. HyperTerminal 
forces a board to PROGRAM MODE by RTS line. PIC programs can not be executed if HyperTerminal 
occupies the RS-232 port. We advise to use Micro-IDE terminal window instead of HyperTerminal. 
 
Expansion 
Most of the micro-controller pins and the 5-Volt power supply lines are available on the 20-pin MINI-
MAX/P18 Expansion connector (J4) for interfacing to external circuitry, prototyping boards and peripheral 
boards. MINI-MAX/P18 peripheral boards can be connected either as a piggyback daughter-board on 
MINI-MAX/P18 using standoffs or can be placed up away from MINI-MAX/P18 using a 20-wire ribbon 
cable. Peripherals section lists the available expansion boards. Table 4 shows the pin assignments for 
the MINI-MAX/P18 Expansion connector. 
 
 

MINI-MAX/P18 Expansion (J4) 
 

Signal Pin Pin Signal 
RC7 20 19 RC6 
RB6 18 17 RB3 
RC1 16 15 RA4 
RC0 14 13 RA5 
RB7 12 11 RC2 
RA0 10 9 RA1 
RC5 8 7 RA2 
RC3 6 5 RC4 
VCC 4 3 GND 
VCC 2 1 GND 

 
Table 4 

Signal Pin 
Not Connected 1 
Receive (RXD) 2 
Transmit (TXD) 3 
Not Connected 4 
Ground 5 
Not Connected 6 
RTS  7 
CTS  8 
Not Connected 9 
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Peripherals  
 
MINI-MAX/P18 can be connected to a wide variety of low-cost peripheral boards to enhance its 
functionality. Some possibilities are: 
 
• Prototyping board (PROTO-1) 
• Training Board (TB-1) 
• 4-digit 7-segment  LED display board 
• 12-bit Analog-To-Digital Converter Board  
• Digital Input/Output Expander Board 
• Real time clock + 128 MB flash card board 
• Terminal board 
• Reed relay board with 4 relays 
• Power relay board with 2 relay 
• Stepper motor driver board 
 
Peripheral boards can either be stacked on top of MINI-MAX/P18 using stand-offs or connected in a 
chain configuration using flat ribbon cable. Figure 2 shows how MINI-MAX/P18 can be connected to a 
peripheral board in a stacked fashion. Figure 3 shows chain connection. 

 
Figure 2 

 

 
 

Figure 3 
 
More details concernig BiPOM Peripheral boards are available from the link below: 
 
www.bipom.com/peripherals.php 
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RS232 Devices 
Various keypads and terminals may be connected to the RS232 port of MINI-MAX/P18 through 
connector J2. MINI-MAX/P18 can be connected to a host PC through the RS232 port. For example, 
MINI-MAX/P18 can be used as a remote data acquisition or control unit serving a host PC in a client-
server configuration. 
Connection to a host PC is accomplished by using a NULL-Modem cable. MINI-MAX/P18 end of this 
cable should be a 9-pin Female D connector for connection to J2 on the MINI-MAX/P18 board. Host PC 
end of this cable can be either 9-pin Female or 25-pin Female D Connector depending on available serial 
(COM) ports on the host PC. 
MINI-MAX/P18 board comes with a NULL modem (LapLink) cable that has the following wiring 
connections: 
 

MINI-MAX/P18 9-pin 
Female 

  Host PC 9-pin Female 

RECEIVE DATA (RXD) 2 3 TRANSMIT DATA (TXD) 
TRANSMIT DATA (TXD) 3 2 RECEIVE DATA (RXD) 
GROUND 5 5 GROUND 
RTS 7 8 CTS 
CTS 8 7 RTS 

 
MINI-MAX/P18 9-pin Female   Host PC 25-pin Female 
RECEIVE DATA (RXD) 2 2 TRANSMIT DATA (TXD) 
TRANSMIT DATA (TXD) 3 3 RECEIVE DATA (RXD) 
GROUND 5 7 GROUND 
RTS 7 5 CTS 
CTS 8 4 RTS 

 
Table 5 
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Software 
 
MPASM development system provides a lot of examples for the MINI-MAX/P18 board to access on-
board peripherals and perform self-diagnostics. 
 
Please download the development system from www.bipom.com/mmpicsoft.php 
Also, WinLoad Windows Loader is available to download program codes to the MINI-MAX/P18: 
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Board Layout 
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Schematics 
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TB-1 TRAINING BOARD 
 
Overview 
 
Training Board TB-1 allows performing various experiments with most microcontrollers.  
TB-1 features: 
 
• 3 Traffic light LED’s ( red, yellow, green ) 
• 2 interrupt inputs 
• 2 switch inputs ( in parallel with interrupt inputs ) 
• 2 timer/counter inputs 
• 4 channels of 8-bit analog inputs 
• Programmable buzzer 
• Expansion bus to other boards 

 
TB-1 is already connected to the MINI-MAX/P18 board as part of the MicroTRAK. 
 
Specifications 
 
Dimensions are 2.35 X 2.40 inches ( 5.97 X 6.10 centimeters ). 
Mounting holes of 0.125 inches ( 3 millimeters ) on four corners. 
0° - 70° C operating, -40° - +85° C storage temperature range 
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Board Layout 
 
Layout of TB-1 board is shown below: 
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Functional Blocks 
 
Expansion 
TB-1 is connected to MINI-MAX/P18 and other boards through the Expansion Connector ( J1 ). 
Table 4 shows the pin assignments for the Expansion Connector. 
 

Expansion (J1) 
 

Signal Pin Pin Signal 
P3.0 20 19 P3.1 
P3.2 18 17 P3.3 
P3.4 16 15 P3.5 
P3.6 14 13 P3.7 
P1.0 12 11 P1.1 
P1.2 10 9 P1.3 
P1.4 8 7 P1.5 
P1.6 6 5 P1.7 
VCC 4 3 GND 
VCC 2 1 GND 

 
Table 4 

 
LED’s 
TB-1 has 3 Light Emitting Diodes ( LED’s ) that are connected in a traffic light pattern. Red and green 
LED’s are on each side and the yellow LED is in the middle. 
LED’s are driven by a 7407 buffer ( IC2 ). Each LED has two pins; cathode ( negative terminal ) and 
anode ( positive terminal ). The current through the LED’s are limited through current limiting resistors 
that tie the anode pins to Vcc. To turn an LED on, the cathode is pulled to ground through the 
corresponding gate of the 7407 buffer. To turn an LED off, the corresponding gate of the 7407 buffer is 
deactivated by setting the input of the gate to a logic high level. 
 
Buzzer 
Because the buzzer requires higher current than the LED’s, buzzer is driven by three 7407 buffer gates 
that are connected in parallel. Due of the inductive nature of the buzzer, a freewheeling diode ( D4 ) is 
used to clamp reverse voltages that may be induced on the buzzer when the buzzer is being turned on or 
off. 
 
Buttons 
There are 2 push buttons on the TB-1. Each button is connected through a protection resistor to an 
interrupt input ( P3.2 and P3.3 ) on the micro-controller. Pressing a button forces a logic low level on the 
corresponding micro-controller input. 
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Interrupt Inputs 
Port pins P3.2 and P3.3 can be used either as general-purpose inputs/output or as interrupt inputs.  A 
high to low logic transition or a low logic level on those inputs can cause a hardware interrupt to be 
generated. 
 
Timer/Counter Inputs 
Port pins P3.4 and P3.5 can be used either as general-purpose inputs/output or as timer/counter inputs.  
Logic level changes on these inputs can be counted by the timer hardware on the micro-controller 
eliminating the need for software polling loops. 
 
Analog/Digital Converter (ADC) 
TB-1 has a type ADC0834, 4-channel, 8-bit Analog/Digital converter. Analog inputs are available on X1 
terminal block.  Analog/Digital Converter is controlled by the micro-controller through 4 port lines. Chip 
Select (CS ) is an input to the ADC. Chip Select enables data conversion when it is logic low and 
disables data conversion when it is logic high. Clock is an input to the ADC. Mode of operation ( single-
ended versus differential ) and channel number is entered through the DI pin one bit at a time ( on every 
transition of the Clock input ). The 8-bit data that corresponds to the voltage on the selected channel is 
output on DO one bit at a time ( on every transition of the Clock input ). 
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TB-1 Schematics 
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Advanced Project Ideas 
 
 

• Using the MicroTRAK as a frequency counter: Student develops a PIC® program to measure the 
frequency and/or period of an incoming signal using PIC18F458’s interrupt inputs. The results are then 
displayed on the terminal window. Input signal is provided from a lab signal generator. 
 

• Using the MicroTRAK as a temperature controller: Student develops a PIC® program to connect LM35 or 
similar temperature sensor to the analog inputs. Depending on the temperature reading one of red, 
yellow or green LED’s are illuminated. If the temperature goes above a preset threshold, the buzzer 
sounds. 
 

• Using the MicroTRAK EEPROM and the Analog-To-Digital Converter as a multi-channel data logger. 
 
 
 


